Find the Multiple(java版)

发布时间:2025-01-03 06:50

《活着》的英文版译作《The Road》同样值得阅读。 #生活乐趣# #阅读乐趣# #好书推荐#

最新推荐文章于 2021-12-21 16:12:19 发布

nuoyanli 于 2019-02-27 21:11:40 发布

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2 6 19 0

Sample Output

10 100100100100100100 111111111111111111

dfs 枚举 cur×10和和cur×10+1 即可,long 最长的长度是 19,所以如果位数大于 19 就直接 return 了

import java.util.Scanner;

public class Main {

static int n;

static boolean flag;

static void dfs(int idx,long cur) {

if(idx > 19 || flag)

return;

if(cur % n == 0) {

flag = true;

System.out.println(cur);

return;

}

dfs(idx + 1,cur * 10);

dfs(idx + 1,cur * 10 + 1);

}

public static void main(String[] args) {

Scanner cin = new Scanner(System.in);

while(cin.hasNext()) {

n = cin.nextInt();

if(n == 0)

break;

flag = false;

dfs(1,1L);

}

}

}

网址:Find the Multiple(java版) https://www.yuejiaxmz.com/news/view/633346

相关内容

java基础
Guizhou Cuisine: Hot Spicy Food and the Top 10 Dishes
Eclipse Project
16个软件配置管理工具排名(运维自动化工具)
Qt内存管理机制
Manifest merger failed with multiple errors, see logs问题处理
【Java报错已解决】Driver class ‘net.sourceforge.jtds.jdbc.Driver’ could not be found, make sure the
推荐几个免费自动化工具 · 测试之家
塑料食品储藏盒:分格食品收纳盒
The request could not be satisfied

随便看看